Fuel pump filter problem - Hyundai Genesis Forum
Hyundai Genesis - Problems & Warranty Info This is where you can discuss any technical problems you're having the Hyundai Genesis platform or Warranty issues.

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 02-13-2017, 05:12 AM Thread Starter
Junior Member
 
Join Date: Feb 2017
Posts: 2
HotWheeleR is on a distinguished road
(Thread Starter)
Fuel pump filter problem

Hi folks,
I am new to the forum. Decided to post here and ask for advice from someone who knows technical details of the 2009 Genesis. Recently I had hard time starting my Genesis. I thought that something was wrong with sparks or coils, so took it to teh guys who's got that OBDII code reader. And it showed bad fuel pressure. Assuming that the fuel filter is clogged, I decided to replace it. I decided to do the job by myself. Everything went fine, I bought the new filter which is good, took the old one off (it was very clogged, by the way), installed the new one in but the problem did not disappear. Now I took the vehicle to check error codes again, and now it throws fuel pump error. I checked in the internet, and it looks like there is another filter inside of the fuel pump. I was wondering, if anyone here tried replacing the pump by themselves? And if so, just wanted to ask, whether it is better to save and get the filter replaced only, or this is a hassle and I'd better go with the new fuel pump?
HotWheeleR is offline  
post #2 of 2 Old 02-14-2017, 02:39 AM Thread Starter
Junior Member
 
Join Date: Feb 2017
Posts: 2
HotWheeleR is on a distinguished road
(Thread Starter)
Ok folks, I decided to give it a try and get the fuel pump filter replaced separately (https://www.carid.com/fuel-pump-filters/). Or at least try doing that. In any case, this is not my daily driver, so even if something goes wrong and I break the pump I will have to get a new one that goes with the filter in it already. And if I will be lucky enough, I will manage to fix the OE pump... So we'll see how it goes.

Last edited by HotWheeleR; 02-15-2017 at 12:44 AM.
HotWheeleR is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome