Possible BOV issue?! - Hyundai Genesis Forum
The HOWTO or FIX Forum Got a How To article or fix it yourself article to share?

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 02-26-2015, 07:42 AM Thread Starter
Senior Member
 
780gervais's Avatar
 
Join Date: Apr 2009
Location: Edmonton, Alberta, Canada
Posts: 143
780gervais is on a distinguished road
(Thread Starter)
Possible BOV issue?!

Hey everyone!

My car is completely stock other than intake (2010 2.0t with 116,000km), and I had an issue with my BOV about 3 or 4 months ago, where all of a sudden when I was driving, it was like my BOV was venting constantly and not holding any boost, would still drive and run, just any time I would start accelerating, would have the issue. I ended up just taking the BOV off and it was stuck open (pushed all the way down when I was holding it diaphram side up) so I just loosed the seal and re-installed and it worked perfect up till Tues night. Did the same thing again, so I took it off, loosened the seal and reinstalled but no luck, still constant vent! (I think) When I take the vacuum line off of the BOV (still has vacuum going to the BOV) you can kind of hear what sounds like the diaphram popping back and forth, and the car changes idle a tiny Bit. But still doesn't hold boost. The car also threw a P0068 code like 20 min before this happened, but no BOV issue. So I drove it home, parked it and when I went back to look, I had the venting issue as soon as it started. I did a soap test on all the vacuum lines and intercooler piping and didn't appear to have any leaks. Also, I couldn't remember when at idle if the soft piping of the intercooler should have any pressure inside of them? Because they are quite soft when idling!



Does anyone have any insight as to what it could be??

Thanks in advance!!

Last edited by 780gervais; 02-26-2015 at 08:04 AM.
780gervais is offline  
post #2 of 2 Old 02-26-2015, 10:31 AM Thread Starter
Senior Member
 
780gervais's Avatar
 
Join Date: Apr 2009
Location: Edmonton, Alberta, Canada
Posts: 143
780gervais is on a distinguished road
(Thread Starter)
Or maybe could it be the solenoid that the BOV Is attached to?
780gervais is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome